Wednesday, 24 March 2010

DeCSS on Ubuntu 9.10 and later

It used to be the case that enabling DVD playback on Ubuntu was a case of installing ubuntu-restricted-extras and that was that. Unfortunately DMCA nonsense in the US has buggered that up for all of us and so now there's an additional step.

So, without further ado, here are the commands that need to be run at a command line:

sudo apt-get install libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh

Voila! DVD playback a-la Ubuntu.

2 comments:

jrfoleyjr said...

WRONGO... I tried this under the new version "LUCID" that I am running and that script is no longer there

Chris said...

Worked for me on maverick. Thanks!

Post a Comment